New 32 and 64 bit XIPAR released!

Discussions about this interesting Xelatec product
kuggie
Site Admin
Posts: 18
Joined: Tue Nov 09, 2010 12:53 pm

New 32 and 64 bit XIPAR released!

Postby kuggie » Thu Feb 28, 2013 2:50 am

There is a new version of the Xelatec Open Source IP Telecommunications (XOSIPT) package including the XIPAR Amateur Radio server.

This revision of the packages is based on CentOS 6, Asterisk 1.4.44, FreePBX 2.9 and Webmin 1.62. A 64 bit operating system release is available as well as a traditional 32 bit release.

For a x86_32 bit installation, boot the iso, and follow the prompts on the screen. Choose #3 for Amateur Radio.

For a x86_64 installation, boot the iso, type 364x and hit enter, follow the prompts on the screen.

Selection 3 XIPAR
64 bit O/S
x experimental

Go to the XIPAR download page to get the new iso:
http://www.xelatec.com/xipar/netinstall

This install does NOT require you to go through the Web GUI, press the ADMIN tab, then choose PBX SETUP, and press the magic orange button after the installation has completed. :D

Enjoy!
Kevin - WJ8G

W2GLD
Posts: 8
Joined: Fri Oct 07, 2011 1:13 am
Location: Pinckney, Michigan
Contact:

Re: New 32 and 64 bit XIPAR released!

Postby W2GLD » Tue Apr 30, 2013 5:21 pm

Does not work on Dell Optiplex GX280 or Optiplex GX520/620 either... I just downloaded in and it generates an kickstart error regarding eth0 not being able to start or find device... Never had this problem on these computers prior, all running CentOS and Fedora... Tried the old media and looks like we're done; can't even install a new AllStar node with older media now either... Tried three different Dell computers that all worked for IRLP and EchoIRLP. Reinstalled CentOS 5.9 and the network cards all work just fine... Weird... The severe lack of documentation for AllStar is such a turnoff for many hams out here...

kb3ors
Posts: 49
Joined: Wed Nov 10, 2010 10:58 pm

Re: New 32 and 64 bit XIPAR released!

Postby kb3ors » Sat May 04, 2013 9:33 pm

This has been found to be an issue on certain computers. Most of them have been Dell. If you have an external ethernet card you can plug in it will load. Once the load is complete, you can disconnect that card and the internal will work. Its a fluke.

KB3ORS
Brian
KB3ORS - Brian

W2GLD
Posts: 8
Joined: Fri Oct 07, 2011 1:13 am
Location: Pinckney, Michigan
Contact:

Re: New 32 and 64 bit XIPAR released!

Postby W2GLD » Sun May 05, 2013 4:40 pm

KB3ORS, thanks for the info... However, putting another network card in the SFF Dell Optiplex GX280's is rather difficult because of several capacitors that are installed alongside the only two PCI slots and these machines, sometimes, at least, require special Dell Only cards... This seems stupid that XIPAR just couldn't update the image as this issue has occurred with various installations of CentOS 6 and there is a fix that can be implemented within the .iso... Simply stupid...

W2GLD
Posts: 8
Joined: Fri Oct 07, 2011 1:13 am
Location: Pinckney, Michigan
Contact:

Re: New 32 and 64 bit XIPAR released!

Postby W2GLD » Tue Sep 17, 2013 12:14 pm

It there a recommended hardware platform for running the x64 release? HP, Dell, Beagle Board-xm with LOX, etc? I've got a ton of Dell equipment available, but after attempting this with three different model line ups and having no luck; I'm beginning to see a trend here... Also, one of the Dell's we used, Optiplex GX620 is now toast after trying to run CentOS 6 for a few days in a native install. Not sure if this is related to CentOS 6 or just an unlucky hardware failure.

In any case, we're trying to build up a fairly robust platform for future expandability; given x64 is the trend moving forward, I think we'd like to go that direction; unless the Beagle Board-xm with LOX is more than enough. Also, we're leaning toward XIPAR because of it's advanced functionality; or at least so we're told...

Suggestions, comments, etc. are all welcome!

Thanks,

Jerry, W2GLD

W2GLD
Posts: 8
Joined: Fri Oct 07, 2011 1:13 am
Location: Pinckney, Michigan
Contact:

Re: New 32 and 64 bit XIPAR released!

Postby W2GLD » Wed Sep 25, 2013 3:55 pm

Does this forums group even get used for support??? Is there a DVD image that I can burn to complete this installation at this point??? I've now tried literally 10 different PC's, ranging from Dell, HP, IBM and NONE of these will allow this installation to complete; they all generate one error or another, most recently that the repository doesn't exist and then it aborts the install. The hardware I'm using is quite robust for this application, but for some reason, this network install is crap... The ACID client installs on all of the hardware I've tested, but we'd really like to run the XIPAR build; they old build under Fedora loaded no problem, but this CentOS 6 version will NOT load no matter what we try, all due to this crappy network install method. I can install CentOS 6 on all of the tested boxes without incident, but not the XIPAR client. What gives??? Hello, is there ANYONE out here to provide support? I'm beginning to think we're just pissing in the wind anymore with Allstar...

W2GLD
Posts: 8
Joined: Fri Oct 07, 2011 1:13 am
Location: Pinckney, Michigan
Contact:

Re: New 32 and 64 bit XIPAR released!

Postby W2GLD » Thu Sep 26, 2013 1:21 am

Okay, well I'll keep adding notes here in hopes that we can build some sort of actual support forum. Anyway, after testing another Dell Optiplex 760 desktop, here's something interesting I found. When attempting to install XIPAR, I initially received a rather large exception message and then the installer terminated. I went into the Dell bios and turned off the TPM Security device and cleared it's profile; restarted the XIPAR x64 installer and at the moment, it appears that it's now working. This is a Dell Optiplex 760 Desktop model, 3.16 MHz. Intel Core 2 Duo x64 Processor, 8gigs RAM and 250gig harddrive. Will report back on this installations outcome...

W2GLD
Posts: 8
Joined: Fri Oct 07, 2011 1:13 am
Location: Pinckney, Michigan
Contact:

Re: New 32 and 64 bit XIPAR released!

Postby W2GLD » Thu Sep 26, 2013 3:38 pm

Well it looks like we may have a successful install... We're currently listening to the WAN-RS via an iaxRpt client on our Windows 7 box. Now on to attempt the configuration challenges...

W2GLD
Posts: 8
Joined: Fri Oct 07, 2011 1:13 am
Location: Pinckney, Michigan
Contact:

Re: New 32 and 64 bit XIPAR released!

Postby W2GLD » Fri Jan 03, 2014 3:32 pm

For those interested in a low power, no moving parts installation; I've been successful at getting this latest version of XIPAR working on an Intel D2500HN with a Crucial V4 32gig SSD drive and four URIx devices; all running on a 13.8v power supply with less than 2.0amps of draw and no need for fans, etc.

n3ssl
Posts: 1
Joined: Wed Aug 10, 2011 6:25 am

Re: New 32 and 64 bit XIPAR released!

Postby n3ssl » Mon Dec 01, 2014 9:56 pm

Today i upgraded to 64 bit version and had some issues with the orange apply configuration. It appears before you accept the config changes you have to update all of the PBX add-on. had to reload twice. after doing the upgrade and than applying changes all worked as normal.

Ryan n3ssl


Return to “XIPAR Distribution”

Who is online

Users browsing this forum: No registered users and 1 guest